contrib/mercurial.spec
changeset 1273 ab22af71386f
parent 563 42a6a41ab76b
child 1890 d4545f1b8bfa
equal deleted inserted replaced
1272:060c08bf9e2f 1273:ab22af71386f
     1 Summary: Mercurial -- a distributed SCM
     1 Summary: Mercurial -- a distributed SCM
     2 Name: mercurial
     2 Name: mercurial
     3 Version: 0.6
     3 Version: 0.7
     4 Release: 1
     4 Release: 1
     5 Copyright: GPL
     5 License: GPL
     6 Group: Development/Tools
     6 Group: Development/Tools
     7 Distribution: RedHat
       
     8 Source: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
     7 Source: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
     9 Packager: Arun Sharma <arun@sharma-home.net>
     8 URL: http://www.selenic.com/mercurial
    10 Prefix: /usr
       
    11 BuildRoot: /tmp/build.%{name}-%{version}-%{release}
     9 BuildRoot: /tmp/build.%{name}-%{version}-%{release}
    12 
    10 
    13 %define pythonver %(python -c 'import sys;print ".".join(map(str, sys.version_info[:2]))')
    11 %define pythonver %(python -c 'import sys;print ".".join(map(str, sys.version_info[:2]))')
    14 %define pythonlib %{_libdir}/python%{pythonver}/site-packages/%{name}
    12 %define pythonlib %{_libdir}/python%{pythonver}/site-packages/%{name}
    15 
    13 
    16 %description
    14 %description
    17 
       
    18 Mercurial is a fast, lightweight source control management system designed
    15 Mercurial is a fast, lightweight source control management system designed
    19 for efficient handling of very large distributed projects.
    16 for efficient handling of very large distributed projects.
    20 
    17 
    21 %prep
    18 %prep
    22 
       
    23 rm -rf $RPM_BUILD_ROOT
    19 rm -rf $RPM_BUILD_ROOT
    24 
    20 %setup -q
    25 %setup -q -n %{name}-%{version}
       
    26 
    21 
    27 %build
    22 %build
    28 
       
    29 python setup.py build
    23 python setup.py build
    30 
    24 
    31 %install
    25 %install
    32 
       
    33 python setup.py install --root $RPM_BUILD_ROOT
    26 python setup.py install --root $RPM_BUILD_ROOT
    34 
    27 
    35 %clean
    28 %clean
    36 rm -rf $RPM_BUILD_ROOT
    29 rm -rf $RPM_BUILD_ROOT
    37 
    30 
    38 %files
    31 %files
    39 %defattr(-,root,root,-)
    32 %defattr(-,root,root,-)
    40 %doc doc
    33 %doc doc/* contrib/patchbomb *.cgi
    41 %dir %{pythonlib}
    34 %dir %{pythonlib}
    42 %{_bindir}/hgmerge
    35 %{_bindir}/hgmerge
    43 %{_bindir}/hg
    36 %{_bindir}/hg
    44 %{pythonlib}/templates
    37 %{pythonlib}/templates
    45 %{pythonlib}/*.pyc
    38 %{pythonlib}/*.py*
    46 %{pythonlib}/*.py
       
    47 %{pythonlib}/*.so
    39 %{pythonlib}/*.so