diff setup.py @ 1697:7b4128f689bd

Merge with crew
author Matt Mackall <mpm@selenic.com>
date Sun, 05 Feb 2006 22:18:38 -0600
parents 43d3db1b8296
children a2316878f19d
line wrap: on
line diff
--- a/setup.py
+++ b/setup.py
@@ -81,7 +81,7 @@ try:
           author='Matt Mackall',
           author_email='mpm@selenic.com',
           url='http://selenic.com/mercurial',
-          description='scalable distributed SCM',
+          description='Scalable distributed SCM',
           license='GNU GPL',
           packages=['mercurial', 'hgext'],
           ext_modules=[Extension('mercurial.mpatch', ['mercurial/mpatch.c']),
@@ -92,6 +92,10 @@ try:
                        glob.glob('templates/*.tmpl'))],
           cmdclass=cmdclass,
           scripts=['hg', 'hgmerge'],
+          options=dict(bdist_mpkg=dict(zipdist=True,
+                                       license='COPYING',
+                                       readme='contrib/macosx/Readme.html',
+                                       welcome='contrib/macosx/Welcome.html')),
           **py2exe_opts)
 finally:
     mercurial.version.forget_version()