contrib/mercurial.spec
author mpm@selenic.com
Mon, 27 Jun 2005 22:18:12 -0800
changeset 487 2ad41189bee5
parent 459 7c1952b29656
child 563 42a6a41ab76b
permissions -rw-r--r--
Add initial hook support -----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 Add initial hook support This adds the basic hook code as well as pre and post-commit hooks. Argument passing is by environment variable key/value pairs so that extra data can be passed over time. File lists will generally not be passed to hooks as these can be extremely long (>1M). manifest hash: 45cf9bab432782c391bc9c1c048c84cc75d52740 -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.0 (GNU/Linux) iD8DBQFCwOukywK+sNU5EO8RAsVsAJ9QipR2aKRSSvoRNo+3If6JddUDkwCgkZrM KEmZpUOxhNHqezFVrHDRTjE= =aedm -----END PGP SIGNATURE-----

Summary: Mercurial -- a distributed SCM
Name: mercurial
Version: 0.6
Release: 1
Copyright: GPL
Group: Development/Tools
Distribution: RedHat
Source: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
Packager: Arun Sharma <arun@sharma-home.net>
Prefix: /usr
BuildRoot: /tmp/build.%{name}-%{version}-%{release}

%description

Mercurial is a fast, lightweight source control management system designed
for efficient handling of very large distributed projects.

%prep

rm -rf $RPM_BUILD_ROOT

%setup -q -n %{name}-%{version}

%build

python setup.py build

%install

python setup.py install --root $RPM_BUILD_ROOT

cd $RPM_BUILD_ROOT
find . -type d | sed '1,2d;s,^\.,\%attr(-\,root\,root) \%dir ,' > \
	$RPM_BUILD_DIR/file.list.%{name}

find . -type f | sed -e 's,^\.,\%attr(-\,root\,root) ,' \
	-e '/\/config\//s|^|%config|' \
	-e '/\/applnk\//s|^|%config|' >> \
	$RPM_BUILD_DIR/file.list.%{name}

find . -type l | sed 's,^\.,\%attr(-\,root\,root) ,' >> \
	$RPM_BUILD_DIR/file.list.%{name}

%clean
rm -rf $RPM_BUILD_ROOT $RPM_BUILD_DIR/file.list.%{name}

%files -f ../file.list.%{name}
%doc doc