view contrib/mercurial.spec @ 1950:5f581f337b05

hgk "committer:" bug I've been having an hgk problem with this tree: http://xenbits.xensource.com/ext/linux-ppc-2.6.hg, specifically changeset 93c590d23a53. The problem seems to be that the commit message contains a "committer:" line, which triggers a (relatively unused?) case in hgk.py... Both cases need the dates at the end of the line.
author Hollis Blanchard <hollisb@us.ibm.com>
date Wed, 15 Mar 2006 03:19:16 +0100
parents e5c8e38b788f
children 1ef8ada4370f
line wrap: on
line source

Summary: Mercurial -- a distributed SCM
Name: mercurial
Version: 0.8
Release: 0
License: GPL
Group: Development/Tools
Source: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
URL: http://www.selenic.com/mercurial
BuildRoot: /tmp/build.%{name}-%{version}-%{release}

%define pythonver %(python -c 'import sys;print ".".join(map(str, sys.version_info[:2]))')
%define pythonlib %{_libdir}/python%{pythonver}/site-packages/%{name}
%define hgext %{_libdir}/python%{pythonver}/site-packages/hgext

%description
Mercurial is a fast, lightweight source control management system designed
for efficient handling of very large distributed projects.

%prep
rm -rf $RPM_BUILD_ROOT
%setup -q

%build
python setup.py build

%install
python setup.py install --root $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc doc/* *.cgi
%dir %{pythonlib}
%dir %{hgext}
%{_bindir}/hgmerge
%{_bindir}/hg
%{pythonlib}/templates
%{pythonlib}/*.py*
%{pythonlib}/*.so
%{hgext}/*.py*