view contrib/mercurial.spec @ 612:9cd745437269

On Sat, Jul 02, 2005 at 02:11:34PM -0700, Matt Mackall wrote: # HG changeset patch # User Alecs King <alecsk@gmail.com> On Sat, Jul 02, 2005 at 02:11:34PM -0700, Matt Mackall wrote: > On Sun, Jul 03, 2005 at 12:49:27AM +0800, Alecs King wrote: > > Hg is really very nice. The only feature i miss from git is the > > whatchanged -p, which shows a diff along with a changeset. > > python before, i just dig into the mercurial/commands.py a while and > > see what diff(), dodiff(), export(), show_changeset(), log() would > > normally do. There might be one thing or two missed or wrong. But here > > it is: a '-d' option to 'hg log' showing the diff info. You can use 'hg > > log -d' to show the whole history with the diff or 'hg log -d <file>' to > > show that info of a particular file. And also works with the '-r' > > option. > > Let's use -p. We're going to be combining the global and per command > switch namespace shortly and the global -p will disappear. Okay. '-d' changed to '-p'. Just like 'whatchanged -p', now we have 'hg log -p'. > Also, the argument list for show_changeset is getting a bit unwieldy. This time i remain show_changeset untouched at all. Only changed some bits of log().
author Alecs King <alecsk@gmail.com>
date Mon, 04 Jul 2005 12:15:44 -0800
parents 42a6a41ab76b
children ab22af71386f
line wrap: on
line source

Summary: Mercurial -- a distributed SCM
Name: mercurial
Version: 0.6
Release: 1
Copyright: GPL
Group: Development/Tools
Distribution: RedHat
Source: http://www.selenic.com/mercurial/release/%{name}-%{version}.tar.gz
Packager: Arun Sharma <arun@sharma-home.net>
Prefix: /usr
BuildRoot: /tmp/build.%{name}-%{version}-%{release}

%define pythonver %(python -c 'import sys;print ".".join(map(str, sys.version_info[:2]))')
%define pythonlib %{_libdir}/python%{pythonver}/site-packages/%{name}

%description

Mercurial is a fast, lightweight source control management system designed
for efficient handling of very large distributed projects.

%prep

rm -rf $RPM_BUILD_ROOT

%setup -q -n %{name}-%{version}

%build

python setup.py build

%install

python setup.py install --root $RPM_BUILD_ROOT

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root,-)
%doc doc
%dir %{pythonlib}
%{_bindir}/hgmerge
%{_bindir}/hg
%{pythonlib}/templates
%{pythonlib}/*.pyc
%{pythonlib}/*.py
%{pythonlib}/*.so