Thu, 11 Oct 2007 00:46:54 -0500 revlog: break up compression of large deltas
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:54 -0500] rev 5451
revlog: break up compression of large deltas Python's zlib apparently makes an internal copy of strings passed to compress(). To avoid this, compress strings 1M at a time, then join them at the end if the result would be smaller than the original. For initial commits of large but compressible files, this cuts peak memory usage nearly in half.
Thu, 11 Oct 2007 00:46:53 -0500 revlog: fix caching of buffer objects
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:53 -0500] rev 5450
revlog: fix caching of buffer objects
Thu, 11 Oct 2007 00:46:52 -0500 chunkiter: handle large reads more efficiently
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:52 -0500] rev 5449
chunkiter: handle large reads more efficiently - for large reads, don't attempt to read more than necessary - if we've gathered the exact number of bytes needed, avoid a string copy
Thu, 11 Oct 2007 00:46:51 -0500 revlog: avoid large yields in group()
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:51 -0500] rev 5448
revlog: avoid large yields in group() Split large yields so that the downstream consumer (chunkbuffer) will avoid some pain when reading ahead.
Thu, 11 Oct 2007 00:46:49 -0500 chunkiter: simplify iter logic
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:49 -0500] rev 5447
chunkiter: simplify iter logic
Thu, 11 Oct 2007 00:46:48 -0500 chunkbuffer: removed unused method and arg
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:48 -0500] rev 5446
chunkbuffer: removed unused method and arg
Thu, 11 Oct 2007 00:46:47 -0500 revlog: reduce memory usage in addgroup
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:47 -0500] rev 5445
revlog: reduce memory usage in addgroup - use a buffer to extract the delta from a chunk - avoid concatenating to a compressed delta - use a buffer to directly extra full text from a trivial delta - delete chunk and delta objects after use
Thu, 11 Oct 2007 00:46:45 -0500 mpatch: allow buffer objects for input
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:45 -0500] rev 5444
mpatch: allow buffer objects for input
Thu, 11 Oct 2007 00:46:40 -0500 Merge with crew
Matt Mackall <mpm@selenic.com> [Thu, 11 Oct 2007 00:46:40 -0500] rev 5443
Merge with crew Those crew folks are getting lazy about pulling from upstream before committing.
Tue, 09 Oct 2007 17:44:44 -0500 Merge with crew
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:44:44 -0500] rev 5442
Merge with crew
Tue, 09 Oct 2007 17:25:24 -0500 Merge with -stable
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:25:24 -0500] rev 5441
Merge with -stable
Mon, 08 Oct 2007 18:47:22 -0500 findcopies: fix rename bug
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:22 -0500] rev 5440
findcopies: fix rename bug We've fiddled with this line several times, and an old bug has reappeared from it. Let's take a peek at the history. The original "or" (rev 3674, in 0.9.2 and 0.9.3): http://www.selenic.com/hg/rev/9103dab96093 Then I changed it to an "and" to fix a bug (rev 4304): http://www.selenic.com/hg/rev/4787e2b0dd03 Then for reasons now lost in the mists of time, I dropped half (rev 4399): http://www.selenic.com/hg/rev/93652499bed3 Then we added back the "or" (rev 4416, in 0.9.4): http://www.selenic.com/hg/rev/bb1800a7d7e1 So it seems it ought to be "and".
Tue, 09 Oct 2007 17:22:38 -0500 mq: clarify queue top message
Matt Mackall <mpm@selenic.com> [Tue, 09 Oct 2007 17:22:38 -0500] rev 5439
mq: clarify queue top message
Wed, 10 Oct 2007 15:48:08 -0700 test-convert-darcs: don't let $HOME/.darcs pollute the test environment
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:48:08 -0700] rev 5438
test-convert-darcs: don't let $HOME/.darcs pollute the test environment
Wed, 10 Oct 2007 15:42:00 -0700 convert: refactor sink initialisation, to remove hardcoding of hg
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:42:00 -0700] rev 5437
convert: refactor sink initialisation, to remove hardcoding of hg We also introduce options to explicitly set the source and destination repository types. Improve testing of corner cases a little.
Wed, 10 Oct 2007 15:30:00 -0700 convert: add default constructor for converter_sink
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5436
convert: add default constructor for converter_sink
Wed, 10 Oct 2007 15:30:00 -0700 convert: make contents of "extra" dict available from sources, for sinks.
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5435
convert: make contents of "extra" dict available from sources, for sinks. This breaks hash preservation for hg->hg conversion, as each converted change gets a convert_revision item added to its extra dict. Ugh.
Wed, 10 Oct 2007 15:30:00 -0700 convert: rename convert_svn to svn_source
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 15:30:00 -0700] rev 5434
convert: rename convert_svn to svn_source
Wed, 10 Oct 2007 00:15:33 -0700 convert: report errors more meaningfully if run with --traceback
Bryan O'Sullivan <bos@serpentine.com> [Wed, 10 Oct 2007 00:15:33 -0700] rev 5433
convert: report errors more meaningfully if run with --traceback
Tue, 09 Oct 2007 08:39:37 -0700 osutil: Solaris build fix
Bryan O'Sullivan <bos@serpentine.com> [Tue, 09 Oct 2007 08:39:37 -0700] rev 5432
osutil: Solaris build fix
Mon, 08 Oct 2007 22:45:48 -0700 Fix build error with Sun C compiler.
Bryan O'Sullivan <bos@serpentine.com> [Mon, 08 Oct 2007 22:45:48 -0700] rev 5431
Fix build error with Sun C compiler.
Mon, 08 Oct 2007 21:37:25 -0300 osutil.c: use strncpy instead of strncat
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Mon, 08 Oct 2007 21:37:25 -0300] rev 5430
osutil.c: use strncpy instead of strncat
Mon, 08 Oct 2007 18:47:22 -0500 findcopies: fix rename bug
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:22 -0500] rev 5429
findcopies: fix rename bug We've fiddled with this line several times, and an old bug has reappeared from it. Let's take a peek at the history. The original "or" (rev 3674, in 0.9.2 and 0.9.3): http://www.selenic.com/hg/rev/9103dab96093 Then I changed it to an "and" to fix a bug (rev 4304): http://www.selenic.com/hg/rev/4787e2b0dd03 Then for reasons now lost in the mists of time, I dropped half (rev 4399): http://www.selenic.com/hg/rev/93652499bed3 Then we added back the "or" (rev 4416, in 0.9.4): http://www.selenic.com/hg/rev/bb1800a7d7e1 So it seems it ought to be "and".
Mon, 08 Oct 2007 18:47:21 -0500 osutil: more tidying
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:21 -0500] rev 5428
osutil: more tidying - do_stat -> keep_stat - all_kinds -> !need_stat - simplify main error logic - reorder declarations
Mon, 08 Oct 2007 18:47:18 -0500 osutil: move file list loop to its own function
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:18 -0500] rev 5427
osutil: move file list loop to its own function
Mon, 08 Oct 2007 18:47:17 -0500 osutil: simplify DT_REG support
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:17 -0500] rev 5426
osutil: simplify DT_REG support
Mon, 08 Oct 2007 18:47:16 -0500 osutils: pull file stat loop into its own function
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:16 -0500] rev 5425
osutils: pull file stat loop into its own function
Mon, 08 Oct 2007 18:47:15 -0500 osutil: fold stat paths together
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:15 -0500] rev 5424
osutil: fold stat paths together - simplify st/py_st logic - use stp to point to stat buffer - combine stat paths
Mon, 08 Oct 2007 18:47:14 -0500 osutil: more cleanups
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:14 -0500] rev 5423
osutil: more cleanups - eliminate a level of nesting - untab targets of gotos
Mon, 08 Oct 2007 18:47:12 -0500 osutil: eliminate alloca call
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:12 -0500] rev 5422
osutil: eliminate alloca call - make full_path a PATH_MAX + epsilon local buffer - use strncpy and strncat
Mon, 08 Oct 2007 18:47:06 -0500 osutil: cleanups
Matt Mackall <mpm@selenic.com> [Mon, 08 Oct 2007 18:47:06 -0500] rev 5421
osutil: cleanups - use tabs - eliminate old-style function pointer calls - eliminate weird scoping - eliminate assignment-in-iff - use !foo rather than foo == NULL
Fri, 05 Oct 2007 01:52:53 +0200 Execution bit detection fixes for VFAT on Linux
Rafael Villar Burke <pachi@rvburke.com> [Fri, 05 Oct 2007 01:52:53 +0200] rev 5420
Execution bit detection fixes for VFAT on Linux On Linux VFAT execution mode can be modified, but changes don't persist a filesy stem remount. The current test can be trickled by this. We can help with the det ection of VFAT checking whether new files get created with the execution bits on (as usually these partitions are mounted with the exec option, for convenience) .
Wed, 12 Sep 2007 12:54:36 +0200 churn: simplify code to get terminal width
Christian Ebert <blacktrash@gmx.net> [Wed, 12 Sep 2007 12:54:36 +0200] rev 5419
churn: simplify code to get terminal width
Mon, 08 Oct 2007 22:20:23 +0200 patch: fix git sendmail handling without proper mail headers
Patrick Mezard <pmezard@gmail.com> [Mon, 08 Oct 2007 22:20:23 +0200] rev 5418
patch: fix git sendmail handling without proper mail headers
Mon, 08 Oct 2007 11:18:34 +0800 hgk: allow any extdiff command for visual diff
TK Soh <teekaysoh@yahoo.com> [Mon, 08 Oct 2007 11:18:34 +0800] rev 5417
hgk: allow any extdiff command for visual diff
Sun, 07 Oct 2007 21:56:36 +0300 osutil.c: style fix - delete trailing end-of-line spaces
Giorgos Keramidas <keramida@ceid.upatras.gr> [Sun, 07 Oct 2007 21:56:36 +0300] rev 5416
osutil.c: style fix - delete trailing end-of-line spaces
Sun, 07 Oct 2007 20:45:10 +0200 convert: do not output when trying to load svn bindings
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sun, 07 Oct 2007 20:45:10 +0200] rev 5415
convert: do not output when trying to load svn bindings
Sun, 07 Oct 2007 20:44:54 +0200 convert: split converters into sink/source
Benoit Boissinot <benoit.boissinot@ens-lyon.org> [Sun, 07 Oct 2007 20:44:54 +0200] rev 5414
convert: split converters into sink/source
Sun, 07 Oct 2007 19:03:32 +0200 Test darcs converter
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 19:03:32 +0200] rev 5413
Test darcs converter
Sun, 07 Oct 2007 18:59:03 +0200 convert: fix darcs_source.pull() under windows
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:59:03 +0200] rev 5412
convert: fix darcs_source.pull() under windows
Sun, 07 Oct 2007 18:58:54 +0200 convert: fix darcs_source._run() under windows
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:58:54 +0200] rev 5411
convert: fix darcs_source._run() under windows
Sun, 07 Oct 2007 18:58:44 +0200 hghave: detect darcs client
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:58:44 +0200] rev 5410
hghave: detect darcs client
Sun, 07 Oct 2007 18:58:36 +0200 hghave: reorder check functions and entries
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 18:58:36 +0200] rev 5409
hghave: reorder check functions and entries
Sun, 07 Oct 2007 15:13:50 +0200 Test workingctx exec/link bit for copies.
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 15:13:50 +0200] rev 5408
Test workingctx exec/link bit for copies. Also, make the test runnable on platforms without symlinks.
Sun, 07 Oct 2007 15:07:35 +0200 Fix workingctx exec/link bit of copies on non-supporting systems
Patrick Mezard <pmezard@gmail.com> [Sun, 07 Oct 2007 15:07:35 +0200] rev 5407
Fix workingctx exec/link bit of copies on non-supporting systems
Sat, 06 Oct 2007 22:30:24 +0200 test-manifest: test symlink and exec bit display
Patrick Mezard <pmezard@gmail.com> [Sat, 06 Oct 2007 22:30:24 +0200] rev 5406
test-manifest: test symlink and exec bit display
Sat, 06 Oct 2007 22:30:22 +0200 Display symlink or executable bit with manifest -v
Patrick Mezard <pmezard@gmail.com> [Sat, 06 Oct 2007 22:30:22 +0200] rev 5405
Display symlink or executable bit with manifest -v New output looks like: 644 a 755 * b/a 644 @ l
Sat, 06 Oct 2007 21:19:06 +0200 convert: quote "^" to avoid windows using it as an escape char.
Patrick Mezard <pmezard@gmail.com> [Sat, 06 Oct 2007 21:19:06 +0200] rev 5404
convert: quote "^" to avoid windows using it as an escape char.
Sat, 06 Oct 2007 15:30:15 -0300 Always copy the necessary files before applying a git patch
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Sat, 06 Oct 2007 15:30:15 -0300] rev 5403
Always copy the necessary files before applying a git patch This patch removes the "copymod" attribute from the gitpatch class. AFAICS, that attribute was only used to delay the copying of renamed/copied files if there are no other changes to the target, but in this case, if there are changes to the source, we'll end up copying the wrong version. This should fix issue762.
Sat, 06 Oct 2007 15:30:15 -0300 mercurial_sink: regrab locks in setbranch
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Sat, 06 Oct 2007 15:30:15 -0300] rev 5402
mercurial_sink: regrab locks in setbranch
Sat, 06 Oct 2007 15:30:15 -0300 convert --filemap: reduce memory usage
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Sat, 06 Oct 2007 15:30:15 -0300] rev 5401
convert --filemap: reduce memory usage
Sat, 06 Oct 2007 15:30:15 -0300 convert: change SKIPREV to 'SKIP'
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Sat, 06 Oct 2007 15:30:15 -0300] rev 5400
convert: change SKIPREV to 'SKIP'
Sat, 06 Oct 2007 17:54:33 +0200 Fix bad lambda prototype in workingctx.fileflags()
Patrick Mezard <pmezard@gmail.com> [Sat, 06 Oct 2007 17:54:33 +0200] rev 5399
Fix bad lambda prototype in workingctx.fileflags()
Sat, 06 Oct 2007 14:14:11 -0300 osutil.c: use readdir instead of readdir64
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Sat, 06 Oct 2007 14:14:11 -0300] rev 5398
osutil.c: use readdir instead of readdir64 Some systems (e.g. *BSD) don't have a readdir64 function - the regular readdir already uses 64-bit types. On other systems (Linux, Solaris, ...), if Python was compiled with large file support, Python.h will define _LARGEFILE_SOURCE and _FILE_OFFSET_BITS=64, so that any call to readdir will actually be a call to readdir64. If Python was not compiled with large file support, we probably don't want to define these macros to avoid ABI problems.
Sat, 06 Oct 2007 14:14:11 -0300 osutil.c: include Python.h before the other headers
Alexis S. L. Carvalho <alexis@cecm.usp.br> [Sat, 06 Oct 2007 14:14:11 -0300] rev 5397
osutil.c: include Python.h before the other headers This is recommended by the Python documentation, since Python.h defines some constants.
Fri, 05 Oct 2007 15:01:06 -0700 Add osutil module, containing a listdir function.
Bryan O'Sullivan <bos@serpentine.com> [Fri, 05 Oct 2007 15:01:06 -0700] rev 5396
Add osutil module, containing a listdir function. This is similar to os.listdir, only it returns a sorted list of tuples.
Fri, 05 Oct 2007 23:40:33 +0200 hgk: add basic usage and configuration documentation
Patrick Mezard <pmezard@gmail.com> [Fri, 05 Oct 2007 23:40:33 +0200] rev 5395
hgk: add basic usage and configuration documentation
Tue, 02 Oct 2007 23:28:04 +0200 hgk: add context menu visual diff action
Patrick Mezard <pmezard@gmail.com> [Tue, 02 Oct 2007 23:28:04 +0200] rev 5394
hgk: add context menu visual diff action * * *
Fri, 05 Oct 2007 22:39:36 +0200 hgk: add debug-config command to pass configuration options
Patrick Mezard <pmezard@gmail.com> [Fri, 05 Oct 2007 22:39:36 +0200] rev 5393
hgk: add debug-config command to pass configuration options
Tue, 02 Oct 2007 23:28:02 +0200 hgk: fix right-mouse button handling under macosx
Patrick Mezard <pmezard@gmail.com> [Tue, 02 Oct 2007 23:28:02 +0200] rev 5392
hgk: fix right-mouse button handling under macosx
(0) -3000 -1000 -300 -100 -60 tip