diff src/http/modules/perl/Makefile.PL @ 168:3314be145cb9 NGINX_0_3_31

nginx 0.3.31 *) Change: now nginx passes the malformed proxied backend responses. *) Feature: the "listen" directives support the address in the "*:port" form. *) Feature: the EVFILER_TIMER support in MacOSX 10.4. *) Workaround: for MacOSX 64-bit kernel kqueue millisecond timeout bug. Thanks to Andrei Nigmatulin. *) Bugfix: if there were several "listen" directives listening one various addresses inside one server, then server names like "*.domain.tld" worked for first address only; bug appeared in 0.3.18. *) Bugfix: if the HTTPS protocol was used in the "proxy_pass" directive and the request body was in temporarily file then the request was not transferred. *) Bugfix: perl 5.8.8 compatibility.
author Igor Sysoev <http://sysoev.ru>
date Fri, 10 Mar 2006 00:00:00 +0300
parents ea622d8acb38
children 38e7b94d63ac
line wrap: on
line diff
--- a/src/http/modules/perl/Makefile.PL
+++ b/src/http/modules/perl/Makefile.PL
@@ -13,6 +13,7 @@ WriteMakefile(
     AUTHOR            => 'Igor Sysoev',
 
     CCFLAGS           => "$ENV{NGX_PERL_CFLAGS}",
+    OPTIMIZE          => '-O',
 
     INC               => "-I ../../../../../src/core " .
                          "-I ../../../../../src/event " .