diff src/http/modules/perl/Makefile.PL @ 148:ea622d8acb38 NGINX_0_3_21

nginx 0.3.21 *) Feature: the ngx_http_perl_module. *) Change: the "valid_referers" directive allows the referreres without URI part.
author Igor Sysoev <http://sysoev.ru>
date Mon, 16 Jan 2006 00:00:00 +0300
parents
children 3314be145cb9
line wrap: on
line diff
new file mode 100644
--- /dev/null
+++ b/src/http/modules/perl/Makefile.PL
@@ -0,0 +1,35 @@
+
+# Copyright (C) Igor Sysoev
+
+use 5.006001;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+    NAME              => 'nginx',
+    VERSION_FROM      => 'nginx.pm',     # finds $VERSION
+    PREREQ_PM         => {},             # e.g., Module::Name => 1.1
+
+    ABSTRACT_FROM     => 'nginx.pm',     # retrieve abstract from module
+    AUTHOR            => 'Igor Sysoev',
+
+    CCFLAGS           => "$ENV{NGX_PERL_CFLAGS}",
+
+    INC               => "-I ../../../../../src/core " .
+                         "-I ../../../../../src/event " .
+                         "-I ../../../../../src/os/unix " .
+                         "-I ../../../../../src/http " .
+                         "-I ../../../../../src/http/modules " .
+                         "-I ../../../../../src/http/modules/perl " .
+                         "-I ../../../../../$ENV{NGX_OBJS} " .
+                         "-I ../../../../../$ENV{NGX_PCRE} " .
+                         "-I ../../../../../$ENV{NGX_ZLIB} ",
+
+    depend => {
+        'nginx.c'     =>
+                  "../../../../../src/http/modules/perl/ngx_http_perl_module.h"
+    },
+
+    PM => {
+        'nginx.pm'    => '$(INST_LIBDIR)/nginx.pm'
+    }
+);